Рубрики
WEB-сервер

Composer видит неправильную версию PHP

При использовании альтернативных версий PHP (например при использовании панели ISP manager) может случиться так, что Composer будет ругаться на неподходящую версию PHP

- This package requires php >=7.1 but your PHP version (5.4.16) does not satisfy that requirement.
Решить проблему достаточно легко.

Подключаемся к серверу по SSH

Редактируем файл .bashrc

$ nano ~/.bashrc

Добавляем алиасы  — добавляем строки с путями к используемой версии PHP

alias php='/opt/php74/bin/php'
alias composer='/opt/php74/bin/php /usr/bin/composer'
export DRUSH_PHP='/opt/php74/bin/php'

Сохраняем Ctr+O, Выходим из редактора Ctrl+X.

$ . ~/.bashrc

Проверяем версию PHP

$ php --version
PHP 7.4.12 (cli) (built: Oct 30 2020 12:09:24) ( NTS )
Copyright (c) The PHP Group

Всё в порядке. Теперь Composer будет видеть правильную версию PHP

 

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *